Samsung Galaxy Book3 360 and 360 Pro

I’d love to work on a 15.6" screen. (My 2017 Notebook 9 pro 15 is…, well, 15". And that’s great, but… That extra .6" translates to rather a lot of space when you compare.) And the 2880 x 1800 display… That’s higher than my desktop beast. Must be really nice to work on.

It’s actually even bigger than that- 16", 16:10 ratio!!! Tasty. Mmmmmmmm… :smiley: They say it’s as wide as my 15.6" 16:9 model, but almost 1" taller. Sounds lovely to me, honestly.

3 Likes

Okay, I spent a non insignificant portion of this morning rebooting my machine, and deleting the Windows update folder, so I’m willing to consider getting a Galaxy Book 3 Pro 360.

My questions are:

  • in Windows 11 is it possible to select text using a Staedtler Noris Digital Stylus in a natural fashion
  • does Windows 11 allow one to install legacy applications such as Macromedia Freehand and then draw in them?

Okay, I traipsed over to the local Best Buy to see what I could find out.

When handed a stylus and asked to select text using it on my Samsung Galaxy Book 12, the BB employee had no problem doing so, but when prompted to try the Book 3 Pro 360, was completely stumped and unable to select text, until I explained that this was done by press-holding on a word until it became selected and had little extension hooks which allowed modifying the selection.

How does anyone stand working thus?

Original behavior (which is the same as it has been since PenPoint/Windows for Pen Computing:

  • press where one wants the selection to being, drag to where one wants it to end, release — selection made

Current behavior:

  • press-hold until one gets a word selected
  • drag a tiny control to extend the selection and release

Why is this still this way?

1 Like

I dislike this as well, I preferred the old behavior for pen or the android behavior for selecting text (with the extension hooks but you can immediately select and hold text to not loose precious times).

1 Like

Is it still impossible to draw in legacy applications because the stylus scrolls rather than functioning as a stylus?

@whoa Could you try installing some legacy drawing application and see if it is possible to draw in it? Say Adobe Illustrator CS2, or an old copy of CorelDraw, or Serif’s old free drawing app? Ideally you could try out Macromedia Freehand MX (that’s the one application I need to know works).

Windows Ink by the sounds of it. On my Wacom, if I have windows ink turned on (old intuous pressure support in photoshop) the latter is how it operates, else with it turned off (I call it “pure mode”) it selects text with the former method. I’m guessing it’s the case with pretty much any and all pennable displays that aren’t directly drivered by Wacom, and it’s a tiny thing that I get over quite quickly when switching between devices. Probably could mofify this behaviour to some degree but it’s no biggie for me, hence never mentioning it!

Nightmare to obtain this, but I’ve found an iso on archive.org and can confirm that it sort of works. It opens fine, but penning in it is hit and miss and not sure if it’s registering pressure/tilt. Worked better when I dropped a compatability mode on it (XP SP3) seemed to pen more consistently but would occasionally drop a line or two. Again, can’t tell if pressure works in this.

Might be a perfect time to upgrade your apps if you’re upgrading the system as a whole (this is not to say go to subscription based route, plenty of free, single-fee perpetual licensed apps out there)

2 Likes

Thanks!

Interesting about Windows Ink — I’d suspected that, but hadn’t been successful at figuring out how to disable it and so forth.

There is no upgrade to Freehand, or alternative, or replacement which works for me — I was one of the beta-testers for Freehand/MX, and none of the alternatives are workable for me (I’ve tried them all — even kicked in money to the Quasado folks when they were stumping for it). I can do w/o pressure (don’t do as much free-form drawing as I used to), but I need all the keyboard shortcuts and other functionality (a side gig includes fixing files which folks have drawn in Adobe Illustrator).

The side gig also involves a lot of copy-pasting of text for tech support e-mails, so I need that feature as well.

I guess I’ll have to see how I feel about a machine if I turn off Windows Ink on one of the demo units.

Thanks!

I broke down and ordered a 1TB unit — should be here by Sunday — we’ll have to see if it sticks, or I pull a dstrauss.

3 Likes

I’ll be interested to see you opinions on the device. It looks very good.

I think the real issue is your issues with Windows and how the pen is now used. I’ve seen your posts, and know that you’ve been unhappy about it for years now. I just don’t see that ever changing, and I don’t see the device being able to solve that problem for you. ??

The solution is EDIT: supposed to be END EDIT to disable Windows Ink which is where this behaviour is implemented — that should then restore things to working as they have since Windows for Pen Computing.

I have to get a machine because I need a new computer for a side gig which requires me to update the software used for certain CNC machines, and I am not constantly sending bogus bug reports for my computer running out of video memory.

We’ll see — there’s a return period, if need be, but it would be nice to have better performance, not so many crashes, and enough disk space to rip all my CDs and so forth.

EDIT: Besides, if I purchase this computer it makes it all the more likely that Samsung will develop a folding dual-screen laptop w/ Wacom EMR.

1 Like

Interestingly the 512GB storage option is no longer available. Wonder why.

Thanks for taking one for the team! :vb-grin:

My pleasure!

I picked it up, and have begun setting it up — a couple of things which weren’t in other reviews:

  • the screen is rounded at the corners?!? Is that the device, or Windows 11?
  • turned off Windows Ink Workspace (at least I tried — applied the registry hack which is supposed to turn it off), but no change on the scrolling issue — is there anything else which can be tried? I did enable the preference to all the stylus to function as a mouse.
  • uninstalled a bunch of stuff

Next up is trying to install Freehand. If that doesn’t work, back it goes.

UPDATE: Freehand works fine:

(and interestingly, the screengrab doesn’t show rounded off corners)

EDIT: One more thing — the stupid stickers aren’t applied neatly under the numeric keypad keys, and the middle one is canted slightly — they’re gonna have to come off.

FURTHER EDIT: Another thing — the stylus at first glance seems much like the base one for the Kindle Scribe — but when directly compared, is smaller (both shorter and narrower), and w/ the button on the fully round side, not in the groove as on the KS stylus. I can’t get it to stick magnetically to the outside of the lid (or outside edge of the base), open or closed, even though reviews have mentioned that — anyone have a photo of that? — it does stick to the Kindle Scribe though.

2 Likes

As far as I know, displays aren’t cut with rounded angles (it would be a waste). So the display is still quadrilateral, but the bezel is rounded.

It’s been a bit of a trend for the last three or so years.

1 Like

Quoted you and replied over in the formal Windows 11 thread — I guess this just shows how badly I needed this machine.

And sometimes I’m just dense — no camera, which I found quite convenient on the tablet — guess I’ll have to work out the Samsung picture sharing stuff and get a tripod for my cell phone.

EDIT: the no silo/storage for the stylus is kind of a pain — also my worry about cracking the screen because I forget and close the lid on a stylus — fortunately, been using it in concert w/ my KS, so I just use the stylus from it. Obvious solution would have been to enlarge the notch in front of the trackpad to accommodate a stylus and made it magnetically dock there.

Further edit — anyone find a suitable sleeve/case/bag?

Further, further edit — found on on eBay: VanGoddy Laptop Backpack Shoulder Bag For 16" Samsung Galaxy Book3 Ultra/Pro 360 and went ahead and ordered it — I’d still like to find a sleeve suited for shorter jaunts.

Hopefully final edit — also found a Timbuk2 “Laptop Utility Sleeve” in a 16" size which was on sale — hopefully one of these will work out. If not, it turns out that the incredibly over-structured briefcase I got for my ThinkPad 755c will work as well (though the straps for the bouncy section are a bit too long), so I have a working fall-back.

Which pen though? The one with the eraser and side button sticks perfectly fine.

1 Like

OIC.

I was trying it along the edge of the display, where it could be useful reached/grabbed ---- never thought to stick it out of the way where it couldn’t be seen or reached.

I use this as a cheap bag for either my samsung 15.6 laptop or my galaxy tab s8u

1 Like

Has anybody tried (or heard of anybody) loading Windows 10 on this machine?

I’ve never tried going backwards before, loading an older OS than the one a machine shipped with and was designed around. (Or sideways; I tried putting Linux on an old Toshiba M200 once. I couldn’t get the screen to take pen input. But that was back in the dark ages.)

But if Win 11 is cranky for pen users, then it only makes sense to roll back to something where usability problems have been solved, (AKA, “beaten into submission” where machines are meant to exist. AI will hunt me down one day).

1 Like