Is my Galaxy Book Flex fast enough? or is it my wifi? or something else?

Looking for some community input from folks more knowledgeable than myself.

I have a 15" 2019 Galaxy Book Flex. I’m using it to HD stream using a dual virtual webcam setup for day long art classes. And I also often run my old Thinkpad Yoga 14 as a secondary host on the zoom call, sharing docs and such with students. The issue is that the laptops are dropping my zoom link some. The Thinkpad is most prone to doing it- 2-3 times a class over a 6 hour period. But I’ve had the Galaxy Book Flex do it a few times too. It’s very frustrating and unprofessional, and I don’t know how to solve it.

I don’t feel like I’m taxing the laptops terribly much, honestly. Yes, I sometimes run the virtual webcams (through Logitech’s LogiCapture program), the zoom call, and perhaps an art program or a Powerpoint presentation sometimes. But the devices seem fine in terms of CPU usage. My wifi is also very good- I’m getting 200-300 MB up and down. More than adequate.

Zoom will crash on the device, but everything else keeps running. I have to log back in. I’ve been pondering getting a newer computer, but I don’t know if the two laptops are the problem anyways. I can’t figure out what the bottleneck is. If it was my wifi, I figure they’d each have consistent issues, but the older Thinkpad 14 (from 2014/15) crashes much more, so it’s got me wondering if its a hardware thing and not a wifi thing. Or if the fact that they both have an older wifi card could be the culprit? Or if a better router would help things?

I would love to get some sort of input on this before I head off to get a new device. I’ve actually wondered if a little min-PC would fit my needs better when running these zoom lessons. But again, I don’t know what the problem really is. As I see it, it’s either-
-my wifi
-my router
-my laptop hardware
-the wifi card

Thoughts?

1 Like

Maybe try a hard line ethernet adapter?

On my previous generation Samsung (Galaxy Book Pro 15) I’ve always found the Wifi to be spotty, but when I use a cable and USB C ethernet adapter, I have excellent, reliable speeds. It could also be the Wifi router in your classroom being unreliable. Wired is always better, I find, and I generally carry around 20’ of flat ethernet cable. (No good for cafes, but if your classroom has an ethernet port, you should be able to leverage that.)

Just a thought.

2 Likes

Hey! Nice to see you, thatcomicsguy. My “classroom” is my studio at my house. So, I have pondered getting a better router, just because everyone here would benefit from the upgrade. Having said that, I did try ethernet the first day. I had such a weird experience.

Bandwidth was stellar, but internet totally cr*pped out on the device only, twice. It was strange, because wifi continued to work on other devices. I rebooted the device, and it happened again, so I relocated elsewhere in the house, and I admit- I didn’t try the ethernet again. I rebooted the router later on (following online tutorials in regards to the ethernet dropping out), but I didn’t want it to happen a third time. What was weird was that wifi on my main device was normally very consistent. Although eventually it dropped it too. The old Thinkpad 14 definitely couldnt’ keep up, and it was just a co-host.

What’s also weird is that when I tested speed with ethernet, it’s great. 1 GBps. And wifi is good too, as I noted.

I’ve thought about ethernet again. It should be best. I ought to give it a go again, as it’s the sort of advice I would give someone else too.

Part of me wants to say its lazy coding on Zoom’s end.

It could still be your router. Pretty much any will give you the speeds that your Internet provider are providing, but cheaper ones often aren’t great at managing traffic (usually just for wi-fi). What model do you have?

It could still be the older devices not being able to keep up, but that could be because newer ones are just better at dealing with a dodgy connection.

1 Like

I agree with @tams that it’s most likely your router, though with a caveat. You don’t mention what brand/model, but especially if you got it through your ISP, it’s likely to be both not configured optimally for multiple devices/connections and have old and buggy firmware installed.

Checking and confirming that would be where I’d start.

As to Zoom, it is what it is, not the best piece software generally. One tip we got from a customer is that if you are using OneDrive, you might want to turn off syncing while you are running Zoom. It’s not clear to us what the actual conflict(s) are, but multiple customers have reported improvement by turning off syncing while using Zoom.

2 Likes

@SteveB Random thought, any chance your CPU is overheating? You could also try turning off CPU intensive tasks like “improve my appearance” and the virtual background. And the obvious one: make sure you’re on the latest Zoom version.

The CPU doesn’t seem to be running hot when I’m doing the meetings. The fans aren’t even kicking on the way they do if I’m processing video. No filters or background. Assume I’m on the latest zoom version. Good question.

I’ll try turning off Dropbox sync the next time I’m doing a lesson. I don’t use OneDrive, but it’s all about bandwidth, right?

The router is what ATT installed. I had them replace it and locate it in a more central area of the house back in August, but they basically told me it was the same model as the old one. Moving it helped speeds for sure. I have a repeater in my studio space now too.

**Just looked at the router- it is an Arris BGW210. I have zero understanding about whether that is any good or not.

I did look up stuff about new routers and wifi6 and its improvements about reliability and speeds. It sounds good. However, my Galaxy Book Flex is from 2019 and I checked- it has wifi 5. Can it be upgraded? I’m assuming not, and that it’s soldered to the board. As for the Thinkpad Yoga 14’s wifi card, who knows? It’s ancient. Although I probably could upgrade it, since its so old. I wonder if that’s even worth doing, its so old…

So a couple of things. I’m not a big fan of that router including the fact that AT&T controls when/how it gets firmware updates.

That being said, spec wise it’s decent, if not outstanding. So, with that in mind, updating or changing your Wi-Fi on your laptops is not likely to gain you much if anything speed or reliability wise.

OTOH the antennas in both your router and your Galaxy book are somewhat more directional than is common. The first thing I’d try is rotating your router 45 or 90 degrees from where it is now on the idea that it might not be optimal in relation to where your book is.

The other thing, which holds true for WIFI routers in general, in use in a home setting, is to have it be as high vertically as practically possible to reduce attenuation from walls, furniture, etc.

There is a fairly lengthy thread on that router on ATT’s support boards as well.

‎Firmware Update for Arris BGW210-700 | AT&T Community Forums (att.com)

Right click on the tray icon and select Check for updates. Or if that option is not there, tap your account pic in the top right of the main zoom window and select Check for updates there.

An ISP wireless router? I’d definitely go to that as the most likely culprit.

It may still be your older machines not handling the connection well, but a more reputable and reliable router could fix that too.

The repeater might also be an issue. I’ve not had a good time with them (not that they don’t work, but they do add more complexity and latency to the whole network). You might be better off with a router with better range and no repeaters.

I recommend an ASUS. Their UI is easy to understand and they’re reliable.

Or if that’s too dear, then:

Even if the issue isn’t your router, at least you’ll still have a good one.