How to disable smart charging in registry?

Recently, the Surface app on my Surface Pro 8 no longer opens and refuses to open. I have already attempted every conceivable method to get it to open, including resetting it, repairing it, reinstalling it, reinstalling the Surface drivers before and after, and a combination of all of these in various orders, and doing a system restart with each remedial attempt. The app remains unable to open. The secondary result is smart charging is permanently enabled and I have no way to disable it. The offshored dunderheads at Microsoft support of course tell me to repeat everything that I’ve already done and then tell me to do a full reset of the system. Honestly, there has to be a way to turn this off, and I suspect the answer lies likely somewhere deep in the system registry. Going off of instinct, I first tried checking under “Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power” and don’t see anything that seems to match smart charging but knowing Microsoft, it probably is named some arbitrary abbreviated name that a manual search won’t turn up. Thoughts or ideas?

With the ginormous caveat that we haven’t tested this at all.

One of our customers who has an SLS (but MS says the relevant hardware/software is the same with the Pro 8 and SLS)

The customer has tried altering in this HKEY the dword value in the “lastattemptstatus” from the default value of 0 to a value 1.


According to the customer this seems to “reset” the smart charging software/hardware. In other words, it likely won’t enable smart charging immediately but after the system goes through the cycles it would do when brand new to turn it on.

FWIW we have seen where changing this value on some thinkpads also serves as reset for inaccurate battery status reporting

So, the usual caveat applies, proceed with exceptional caution


Thanks! I am attempting it now but it doesn’t seem be taking effect after a restart and unplug. Thankfully, no software magic smoke so it doesn’t appear to have done any harm to system stability. I’ll keep tooling around here in this part of the registry though and hopefully it will work!

Good that it doesn’t appear to cause any harm. I would try it myself if I wasn’t out it the field today and thus can’t afford a risk to my system.

Out of curiosity, did you reboot after (because it touches UEFI) and if you did, did it revert the key back to a value 0 ?

Yep. I did a reboot cycle after each attempt of applying the change. I tried applying it both plugged in, and unplugged and then plugging back in (post-restart). I noted as well that this registry value occurs under multiple alphanumeric parenthesized sub-keys/folders. So with both the plugged in and unplugged attempts, I applied the 1 to all instances of LastAttemptStatus (8 in my case).

1 Like

I think I found a “middle” answer here thanks to @Desertlap and @Dellaster advice about getting around Smart Charging. What worked for me just now was enabling the UEFI battery limit, booting into Windows, immediately restarting, and finally disabling the UEFI battery limit. After going through those gyrations, my system seems to have smart charging disabled at this point. On the other hand, there is the other issue of the Surface app refusing to open, but at least we finally found a workaround for forcibly disabling smart charging.


Great discovery! I wondered if enabling the UEFI Battery Limiter would reset things. Now we know. :+1:

1 Like

Thanks! I still think there is an answer hidden in the registry. I have to believe there is some sort of toggle that initiates a signal or trigger to the firmware to turn it off. I imagine eventually someone will uncover the answer to this mystery, but for now this works.