HELP NEEDED - Surface Pro 8 Pen Input Stops Randomly

This happened to me several months ago - quit - and has started again. In the middle of several meetings this week pen input just stops. The screen is not frozen and I can use touch or keyboard to scroll, and I can type text, but the pen does nothing. You can’t just reboot during the meeting (especially Teams/Zoom, although I’ve done that on a teleconference). Sometimes the pen begins to work 3-5 minutes later, other times I need to haul out a notepad to continue.

Anyone else have this problem? Solutions?

I did the usual hard boots; check for driver/other updates - still happens.

1 Like

Pen charging?


Do you have a spare pen so that you can narrow it down? Though it’ll be annoying to wait for it to happen/not happen with the alternate pen since it’s a seemingly random occurance. :thinking:

1 Like

@Bishop - pen is fully charged

@Dellaster - unfortunately no spare.

I forgot to mention this also happened in Word yesterday while annotating a checklist, so it is not a OneNote specific thing. Called MS tech support (still under Complete Care) ran some diagnostics not showing any hardware issues, so they are like “So what software do you use?” and I said “Only happens in Office apps…” and I get the so helpful “hmmmm…”

1 Like

What type of pen is it? Slim Pen 2? My original Surface Pro pen (the silvery round type) had an issue where iirc the screw-on back cap would oxidize a little, or so I think, because unscrewing and retightening a few times would fix an unresponsive pen.

If it’s the Slim Pen 2, does that one come with a spare tip? (Edit: it doesn’t) If not, order the set of 3 spare tips for $25 to see if that’s the issue.

If changing the pen orientation / grip brings back ink, it might be the tip. It’s a bit of a long shot, but you could also try to remove the tip and reinsert it. Supposedly you can just pull out the tip.

Edit: funny, looking for a possible solution I found that years ago, the Surface Pen would reproducibly stop working after 2 minutes and 11 seconds of continuous inking. Incredible! Rotating the pen grip / barrel once in a while allegedly solved it. Some people in that ancient thread claim it still have it to this day, so maybe see if axially rotating your pen fixes it?


That sounds like it would be SOOOOO M$ and SOOOOOOO true!


Surface Pro 8 Pen Input Stops Randomly.”

Well…, there’s your problem right there.

I’m still salty that MS went with N-Trig back in the day.

They’ve come a long way, and kudos to the poor boffins for their thankless efforts to turn a dummy boss’s bright idea into a workable solution, but seriously…, beneath the mighty edifice remains a foundation of sand.

To be fair…, I don’t know if they’ve scrapped that garbage tech and started from scratch or not, but it’s telling that even third party Chinese patent vultures are now shipping better Wacom knock-off boards than MS and Apple these days.


I had similar issues with one of my Surface Pens on the Surface Studio 2, and the intermittent pen dropping out heralded the pen dying completely–I did get a good 9 months out of it before it went, though. I second Dellaster’s idea about getting a second pen. That might help you narrow down the problem (and/or rule out the pen as the source of the disconnect).

1 Like

My apple pencil is also getting that concerning sign, when my pen battery going low. And it had been going low much faster now. I’m guessing once the battery capacity go down to that minimum level , the pen would become unusable.

While i know getting a new pen is the easiest way to test, it makes no sense that we would need to spend 50-70$ on a new pen just to know if the problem is on the screen or the pen. Also while having a spare pen is good with ERM pen, AES pen is not economical to keep more than one. Battery capacity always degrade over time whether you use it or not, in some cases unused battery degrade even faster than often used ones. If you just have an unused spare laying around, that spare battery would be degrading and you would be losing warranty time. It is a lose-lose situation.

I recently picked up an used tab A 2019 with S-pen, it’s still snappy with long battery life, the spen still works great, and it costed 65$, much less than even the Apple pencil gen 1. After my pencil die, i will be moving all my drawing to Samsung and only keep the iPad to consume media.

1 Like

Thanks for everyone’s help, but the problem just keep’s getting worse. I have scoured the web and this seems to be a persistent problem (at least complaint wise) and NOTHING that is suggested by M$ or third parties fixes the problem.

Even worse, OneNote on my iPad Pro 11 still works perfectly (knock on wood) :man_facepalming: :person_shrugging:

I KNOW it’s not the answer for me, but late last night I was trolling the Apple and BestBuy refurb listings again…

1 Like

PS - I tried loading my OneNote notebook on a second Windows 11 machine (non-M$) and getting same result - “Not Responding” after 2-3 minutes of use and every time I switch inks or tools. so I think that eliminates a hardware issue. Since the same notebook still works fine on the iPad Pro I don’t think it is a corrupt data file.

Where’s the emoji for tearing my hair out! Well, not really - if I know I will need to meet for more thana few minutes I bust out the iPad

actually I think it may be the capacitor that powers the slim pen (versus a battery in the standard surface pen) that’s prematurely failing. In other words it’s running out of charge.

This has been an ongoing issue with samsung s-pens as well, specifically with the notes and now ultras whose pens use a similar capacitor type power source.

THAT MAY BE THE ANSWER - I picked up a Samsung Galaxy Book3 Pro 360 from BestBuy Friday to see if it was hardware, but had the same problem with the S-Pen (GORGEOUS AMOLED screen by the way - to me even better than the MBP 14 mini LED). Guess I’ll go get a new Slim Pen 2 when I take the Pro 360 back and see if that fixes the problem. At least I know the Apple Pencil is still working…

PS - on that Pro 360, the trackpad is FUBAR as well. It constantly has random clicks, cursor vectoring, and touches. Perusing tons of posts on web found only one solution - ONLY TOUCH THE BOTTOM 1/4-1/3 of the trackpad. I know, nonsensical, but it was the ONLY solution.

@Desertlap - before I blow another $130 - would the capacitor issue also affect tapping icons or selections onscreen? Sometimes I have to tap the pen icon in OneNote that I want to choose 4-5 times before it selects that new pen tip/color.


After that last question, I did something I should have from the start. I tried writing in both Paint and Drawboard PDF - selecting different colors, tips, etc. and they both worked without a hitch. My problem has to be OneNote on Windows 11 (because it doesn’t happen in OneNote for iPadOS).


I think you may have already answered your specific question/issue. If the pen capacitor hardware is failing, it should be doing so across the board more generally and not app specific.

Well, it IS app specific (OneNote). No problems in Drawboard PDF or Paint, including selecting items. Same goes for Word.

So I closed my law practice notebook and tried an entry on a new page in the base Quick Notes - AND IT WORKS. But if this is a corrupted notebook, why in the world does it work fine in iPadOS (17 beta no less) and not on my SP8 or the Pro 360…

I also can’t get the web version of OneNote to even open the page from my main notebook…

Did I ever mention I HATE COMPUTERS?

Have you tried creating a copy of your law practice notebook and seeing if still experiences the issue? Alternatively, create a blank notebook and import section-by-section, to see when the issue starts occurring.

1 Like

Thanks Marty - that’s next up on the list of time sucks (this is almost as much fun as Tom hanks in Money Pit)…

1 Like

The battery thing on the s-pen doesn’t power the writing, only the air action. The writing with sPen doesn’t require any charge, so if the spen doesn’t work with one note, it should have been software problems of that one note page.

Apple pencil worked likely because the One Note app in iOS use different code, while both the Surface and Galaxy use the same windows Onenote. Once you switch to iOS, it’s already comparing Apple and Orange.

Still shame on M$ if their own software work worse on their own OS…

Edit: sorry missed that you already figured it out

1 Like

Yes, shame on M$, but as Commander Montgomery Scott was quick to say - “Fool me once, shame on you; fool me twice, shame on me!” and now it’s more like “Fool me daily, I am the fool” in this circus. I am bringing it on myself, because surely 1,500,000,000 users world wide can’r be wrong - right? :man_shrugging: