Troubleshooting X220 tablet stuck in boot loop on Win10

Update: hurray, issue resolved. I’ll leave the post up in case anyone else runs into this. So far I’ve seen at least two other people with the same issue on the entire internet over the past decade

Still got my X220t (2011 vintage), but a recent OS update attempt (windows 10 22H2 ) caused the system to get stuck in a boot loop. It will crash with error 0cx000021a, offer to attempt to repair, the and repair fails. Attempts to roll back the update fail, and attempts to get back to a restore point fail.

The good news:

  • safe mode works
  • safe mode with networking works
  • reboot and disable signature checking works (typing this on the X220t right now)

That last one gives me hope that it’s just a driver incompatibility, but it’s surprisingly hard (for me) to figure out the offending driver. Is there a log where Win10 states “hey, this driver signature doesn’t check out, but I’ll allow it because you disabled signature checking”? That seems like an obvious thing to do, but I haven’t been able to locate it.

What I’ve tried so far:

  • clean boot (disable all non-MS services, disable all startup apps in task manager). Not a fix
  • disabled a whole bunch of drivers in Device manager (pen, touch, etc), didn’t help. Still need to try disabling all bluetooth devices
  • uninstalled a bunch of programs (Lenovo System Update and Vantage, Private internet access, etc), didn’t help
  • disabled second SSD, no change
  • looked at recent system errors and warnings in the Event Viewer, nothing jumps out at me
  • Downloaded MS WinDBG Preview from the store to maybe inspect the dump file
  • Looked at C:\windows\system32\LogFiles\srt\SrtTrail.txt Claims “Boot critical file is corrupt.” Great. Which one?
  • ran DISM and ScanSFC (still running, let’s see)

Still to do:

  • Disable more drivers (disabled bluetooth)
  • Run all available updates in Windows Update, but do “advanced reboot” (settings > recovery > advanced startup, then Troubleshoot > Advanced Options > Startup Settings) and disable signature checking so the updates can complete.
  • Install optional driver updates in Windows Update > View all optional updates (installed several of these, two Lenovo System drivers, and an Intel… management engine? update)
  • Noticed some updates didn’t complete with signature check disabled. Ultimately rebooted without ‘disable signature checking’, and it made it!

Not attempted because the issue was fixed:

  • Inspect dump file with MS WinDBG Preview
  • Try some of the following options in an admin cmd prompt: BOOTREC /FIXMBR or with /FIXBOOT or with /scanos or /rebuildbcd

Anyone here have any suggestions based on the symptoms? I feel like the fact that it DOES run with signature check disabled is pretty telling, but I don’t know how to proceed.

Edit: OK, I did too many things to nail down what finally solved it, (ran DISM and SFC, installed several updates including optional driver updates, disabled bluetooth driver) but I’m able to restart without BSOD, and I’m all up to date. I re-enabled most drivers but I still have bluetooth and wacom pen disabled (that one never worked with Win10 anyway).