HP ZbookX2 WIndows 11 woes

It hurts me to say, but I’m on the cusp of retiring my Zbook X2.

So I bought it refurbed back in the fall of 2019 (the 8th gen model) and for two years it served me very well.

Until this fall when there was some sort of failure with the SSD, I had to resort to a system recovery. Saved my files and everything, but with resetting my Windows 10 install…it just didn’t seem to work as well. One of the most annoying problems I was having was when I right click on the desktop, it would give me the spinning circle kind of endlessly. And everything else seemed kind of glitchy. Like right clicking in general and windows explorer operations just seemed eternally prone to mistakes and false/extra clicks.

So I decided to try the Windows 11 update…did the update install where it saves your files. That seemed to resolve the right click problem I was having, but it introduced all sorts of new problems. I couldn’t install Clip Studio Paint, like it would sort of install, but the program would never appear. Photoshop I got up and running but it ran laggy (even on high performance mode). And some of the HP software didn’t carry over, like the Create Control Panel.

So I decided to take all my files off and do a full fresh install of Windows 11, wiped and clean the hard drive and started anew. I just did that a few days ago, was putting it off for a while.

So I did that and it seemed like everything was fine, the HP Software was fully back, and I was able to install Clip Studio with no issues.

Until I started drawing in Clip Studio today…and what the ■■■■ happened to the Multi-touch/Palm Rejection? Either using Windows Ink or the Wintab, the palm rejection was just broken and made drawing with it near unusable. I disabled touch and drawing was now possible, but sort of super annoying without the multi-touch gestures. I’ve been drawing in Clip Studio on Windows 10 devices with the multitouch on and had no problems for years. The Surface Pro 5, Galaxy Book 10, Mobile Studio Pro all had multi-touch issues at all.

So with drawing out of the picture, I decided to do some coding, plugged in my Asus USB-C monitor and had to setup my monitor settings…right clicked the desktop…and spinning wheel error returned. After about 10 minutes, I was finding all the old gltiches had seemingly returned.

So despite doing a fresh install of Windows 11, my Zbook is still glitchy as ever. I bought it refurbed, but it worked so well for 2 years.

Maybe its just time to retire the old girl.

I ask because I made the mistake of not selecting it in settings when I got my SLS: did you turn this on? Ignore touch input when I’m using my pen?

They set it off, unselected, by default for some weird reason.


Hi, what a sad story.

I can’t say I’ve been remotely tempted to try Windows 11 on my X2, but did make what in retrospect might’ve been a mistake by formatting & clean-installing Windows 10 when it was brand new.
It’s had a few minor quirks ever since, so it’s tough to know if it would’ve been any different if I’d left the stock HP image installed.
I took guidance from HP tech support on how to put back only the bits I needed and none of the bloat.

I was curious whether you’d tried a clean install of Win 10?

@darkmagistric Have you tried a Factory Restore from the official Win10 OS image? There is a cloud tool which lists the ZBook x2 G4 as one of the supported models and let you create a bootable USB drive.

1 Like

I did not, didn’t even know that setting was there. I’ll give that a try

@darkmagistric : Hate to say this, but you might have had a motherboard failure. I say this because your symptoms sound somewhat similar to the ones that I experienced when my X2 broke down. It, too, was related to some sort of SSD failure. It took a couple of trips back to HP, but it eventually got fixed. I don’t suppose that you still have any warranty coverage…? If so, you should definitely take advantage of it.

Regarding a Win10 reinstall, HP recommends a particular method which I mentioned in the TPCR forum thread. You might look back to see if you can find the details…

1 Like

@darkmagistric : Just called HP’s Business Support. Don’t know if this will help you, but the current recommendation to reload your OS image is HP Cloud Recovery:

HP Cloud Recovery

The disc image for the X2 is listed near the very bottom of the table (ZBook X2 G4). At the top of the table there are two hotlinks for the instructions and for the download client that apparently needs to be installed to conduct the reload…

Good luck.

1 Like

Yep that did the Trick for fixing the broken Palm rejection…mostly. It still seems to have delays at random, and the line/brush quality seems laggy. But that could be for other reasons in regards to my zBook. All the other glitches persist though.

1 Like

I’ll keep that in mind the next time I try to reload the OS, don’t really have the time this week, and somewhat hesitant to start from scratch yet again…because Screw You Celsys!

When I reloaded my zBook, I had to deactivate my Clip Studio serial number from another device. I’ve done this so many times over the years, but this time I was greeting by a little pop up message, indicating that they are now limiting how many times your Clip Studio License can be deactivated.

It didn’t specify how many times, or how many deactivations I have left with that serial, but clearly they are now actively trying to bully us Windows License owners to embracing the bull ■■■■ of the subscription. (Which I’m already paying for my iPads )


RIP, I know Clip Studio Paint is the preferred program for many illustrators but ■■■■ that subscription model.

Have you had any luck with any of the alternatives: Particularly Krita (free, open source) and Media Bang Paint (multiplatform)?

1 Like

Sorry for going off-topic but I gotta rant a bit:

Medibang paint is severely crippled in function compared to CSP and Krita. What more, their recent subscription model on Android/iOS was worse than CSP: they add ads banner on the drawing space and block many function that used to be free, keep cloud art ransom to force user to pay for subscription. They also removed the one-time-purchase creative pack that remove ads and add some more functions ( which I bought) so those features become subscription - exclusive. After updating to new version, I can no longer restore my purchase if I happen to reinstall the app or moving to new device. The one time purchase was 10$ which was enough to buy Procreate or infinite Painter ( which I moved to for my mobile drawing need)

Krita is pretty cool with some features I wish were on CSP, its biggest problem was the interface wasn’t tablet friendly, so artist who got spoiled by CSP would feel less interested in learning Krita. Krita brush engine was also a tad bit slower than CSP, but it was much improved in the 5.0 update. Now if only they make collapsible panel for the UI.


Did you ever do the Win10 install with the HP factory image @darkmagistric?
If so, how did it go with fixing your glitches?

I heard Celsys would permanently block your ability to switch license if you reactivate license too often ( like once a week). Someone I talked to mentioned they reset their OS every other week when they feel sad, and that led to their license no longer work. If you only reactivate few and far between like half a year, it probably won’t be a problem. The limit seem more about frequency rather than number.

CsP had a term that only allow 2 devices for a license, likely this is a limit put in place to prevent user from switching between more device. If your PC had OS problems, maybe try out the trial mode a bit longer before you be sure the OS is stable and okay.

I never ended up fixing it. More or less gave up as I was switching to a mostly Mac workflow for about 2 years.

(and now with my Pro 8 I’ve switched back mostly to a Windows workflow, funny how that works)

I can’t say I’ve ever used a Mac properly, I began with Windows becasue at the time it was the only OS for professional CAD users and I’ve stuck with it.
I’m not sure what I’ll do when my X2 gives up, the hardware and design is pretty much ideal for my needs and at the moment I don’t know if there’s anything comparable.
That said, I haven’t been looking, so if there’s something similar on the market I should know about, please let me know!

I just got one of these secondhand. It came factory reset (Windows 10) so I had to set everything up and get it running smoothly. I had that right click on desktop spinning circle problem, I think updating the graphics drivers off HP’s website was what fixed that. I haven’t touched Windows 11 on it, Windows doesn’t even recommend it. I would suggest going back to Windows 10 with a clean install and installing all the drivers on HP’s support site. I had to tweak a few other input settings too and now everything feels smooth, and it definitely didn’t when I first got it. I know I had to change some setting to make palm rejection work properly. It still works, it’s still good, it just needs a little setting up from a fresh install.