Continuation of "Zbook X2 Just Announced" thread

This is a continuation of the thread “Zbook X2 Just Announced” of the old TPCR forum, whose latest page 131’s latest post is now archived at Zbook X2 Just Announced | Page 131 | TabletPCReview.com - Tablet PC Reviews, Discussion and News.

And just a copy of my last post there:

@SteveS & @TCassidy thanks for your suggestion! Now it works somehow unexpectedly: previously, I always plug the USB enclosure into the USB 3.x port of ZBx2, and it will get stuck and can’t boot or even not detected by the BIOS. But now, after I plug in a USB Type-C hub (with 4 USB 3.0 slots) to ZBx2, and then connect the USB enclosure to the Type-C hub, it finally and unexpectedly works, because the USB Type-C hub is not externally powered so it solely relies on the power from ZBx2. I thought the regular USB 3.x port should provide more power (than the Type-C port) to the enclosure so that it can be detected in BIOS, but this seems not the case with the regular USB 3.x port on ZBx2. Very strange, but finally, what a huge relief on the last day of the life of this wonderful forum! Unbelievable…

So now I’m finally able to boot into Win 10 on the HDD in USB enclosure. But it seems that there are a lot of unknow devices in devmgmt.msc, even though I’d already used NTLite to integrate all drivers downloaded from HP ZBook x2 G4 Detachable Workstation Software and Driver Downloads | HP® Customer Support. Most of the unknown/missing devices are PCI-related. But this should be a minor and temporary issue… However, the worse issue is that, my ZBx2’s battery is 0%, and even though the AC adapter is plugged in, it’s not being charged as shown in Windows (it shows “0%, plugged in” but without “charging” or similar). I’m not sure if this is related to those missing PCI-related device drivers, or it’s due to the fact that the Windows is booted from an external HDD in USB enclosure.

I got my ZBx2 almost 2 years ago, right before the pandemic. Unfortunately, my work and life was severely affected by covid-19 in the recent years, so I’ve never got the time and energy until last month to seriously investigate Windows 10 customization & deployment and booting into it on my ZBx2 with FreeDOS pre-installed. In fact, almost two years ago, shortly after receiving my ZBx2, I set “Maximize my battery health” in BIOS to limit its charging level to 80%, and then just powered it off and left it on my desk without using it (as I didn’t have the time and energy to do research on Windows customization & deployment etc. until recently), while keeping the AC adapter always plugged in during the recent 2 years. Today is the first time I’m able to boot my ZBx2 into Windows, so I’m not sure if keeping my ZBx2 turned off but with AC plugged in for 2 years without using it while setting the battery config to “Maximize my battery health” had drained the battery so badly to 0% that the battery is now dead… Now I’ve shut it down from Windows start menu (and strangely, sleep is not available and missing from the start menu; not sure if this is related to the fact that I booted from external HDD in USB enclosure), and hopefully the battery can be charged somehow…

Anyway, let’s continue this discussion in a new thread at Slates/Detachables - TabletPCReview Forum. I’ll soon make a backup at https://web.archive.org/ for this page 131, and paste the link into the new thread at Slates/Detachables - TabletPCReview Forum. I can try starting a thread/conversation there, or would you (@SteveS ) like to do it instead?

Having known this forum for almost 15 years and registered almost 14 years ago, I feel both sad and relieved today. And even right now, I still couldn’t believe that this critical BIOS-related issue can be fixed on the last day of the life of this amazing forum, from which I learned and benefitted quite a lot…

2 Likes

@testplayer : If you don’t mind, I’m going to tighten up the title of this thread a little. I was just about to re-establish this thread but you beat me to it!

Yes, please feel free to edit it, and many thanks! :smile:

Some comments:

<> I don’t have the numbers right in front of me, but the USB-C standard does permit more power than the USB-A standard, so no surprise there (the real surprise is that the hub worked!)

<> Regarding the unknown devices, I’ve seen this more than once when a new OS is loaded or the existing OS is refreshed. First try running Windows Update as you will probably see several significant updates that need to be installed to bring you up to date. After that run through the device manager and search for drivers for the “unknown entries.” After that, you may have to contact HP Support for help.

<> Incidentally, HP suggests that OS reinstalls are better handled by a different process. It’s mentioned in this thread on TPCR, but it was some time ago. If time permits, I’ll try to go back and find it.

<> Regarding your battery… I’ve mentioned more times than I care to think about that leaving your computer constantly plugged in is about the worst thing that you can do regarding battery life. Setting the UEFI to 80% was a good thing, but I think that being continuously plugged in takes a toll regardless:

However, your battery may not be (probably isn’t) dead. It’s equally likely to be another missing driver / unknown device issue. You might try unplugging your X2 and seeing if it operates for more than a few seconds…

<> As for this post and its continuation, I see that it is already in the Slates / Detachables forum, so no additional actions needed.

1 Like

@testplayer : Regarding your unknown devices, I just called HP’s Business Support. The current method that they recommend to restore your OS image is HP Cloud Recovery:

HP Cloud Recovery

The official ZBook X2 image is listed near the very end of the table (ZBook X2 G4) and I think the HP tech said that the drivers were available separately. At the top of the table there are two hot links for the User Guide and the download client which you need to install for the process.

Anyway, perhaps this will provide some help…

Thanks so much for the figure. As I understand, if I turned ZBx2 off for 2 years while keeping the AC power plugged in and limiting the max battery level to 80% in BIOS, then the charge and discharge bandwidth should be small enough, maybe always varying between 60% to 80%.

On the other hand, I got the following screenshots when running some tools:



BatteryCare3

These screenshots are taken after booting into Windows 10 on HDD in USB enclosure and leaving it charging for more than 3~5 hours. So it seems that the AC power charging during the recent 2 years never worked and the battery simply failed to get charged?? (I can confirm this, because when I unplugged the AC power plug from ZBx2, it immediately turned off) On the other hand, I’ve noticed that in ZBx2 BIOS, there is a “Fast Charge” setting in the “System Options Menu”, and the explanation (according to official document) is "When checked, battery charge rate is actively managed by the system using current battery and charger parameters. When unchecked, rate is fixed. " I always leave it as checked/enabled, so maybe this is the reason why it never got charged??

As a side note and comparison, here is the battery info of my >7 years old ThinkPad W540:
image
image

Wow, thanks a lot for that! Now it seems that the graphical and some other drivers are not correctly integrated in NTLite when I deployed install.wim:



When I deployed Windows 10 last month for my ThinkPad W540 using NTLite for drivers integration (official drivers downloaded from Lenovo) , it works flawlessly right after OOBE/1st logon, so I never needed to download or install any other drivers manually.

Anyway, I’ll try updating the drivers using the wizard within devmgmt.msc or in Windows update. When there is no unknown device in devmgmt.msc, I’ll then export the drivers using NTLite or DISM++, so that they can be integrated for the next Windows deployment on VHDx, which will be copied to the M.2 SSD on ZBx2.

Regarding the cloud recovery, since I selected FreeDOS when customizing my HPZBx2 and placing my order 2 years ago, am I eligible to restore it to Windows now?

I don’t know for sure, but you might try it. HOWEVER, I was told that the process requires you to enter your serial number at which point the system may determine that you are ineligible for a Windows download.

As for your battery, what happens when you disconnect the charger? That will tell you if your battery is truly dead or not. The BatteryCare readings make we wonder. If the readings were correct, shouldn’t they show at least some wear level and and discharge cycles…?

Yes, as I updated in Continuation of "Zbook X2 Just Announced" thread - #6 by testplayer, when I unplugged the AC power plug from ZBx2, it immediately turned off. So it’s really dead :cry:?

Here’s some information from BatteryUniversity,com, my go-to source for battery, especially Lithium battery, information:

BU-808b: What Causes Li-ion to Die? - Battery University

And yes, I would guess that your battery is dead…

That’s so terrible… :sob: I thought today is my lucky day as being able to get the BIOS/booting related issue fixed on the last day of the old TPCR forum’s life…
Well, as I’m still covered by HP’s 3-year warranty, will I be eligible to get the dead battery replaced by HP?

Update: after checking warranty at HP website, it shows “N-CSR Battery Replace”:
image
However, there are lots of conflicting information regarding this, as many people reported that this mysterious “N-CSR Battery Replace” doesn’t mean HP will be obliged to replace a dead battery…

In general, batteries are only warrantied for a short period of time (e.g., 6 months). However, I would still contact HP and ask…

@testplayer @SteveS Great to see this thread resurrected here, I was wondering about asking if there were other X2 users around and starting one.

On the battery problems, I’ve only skimmed the posts, but it sounds like we’re suffering a similar issue.
I’m still in warranty (just) and although I initially lived with the quirk, (typically a random sudden shutdown shortly after waking from sleep, but otherwise normal function), I’ve since had two battery replacements by HP, which hasn’t solved the problem.
In fact, it’s got a lot worse - HP battery check showed a deterioration in capacity to about 30% over just a few days after replacement both times, but it was still possible to use off AC power as long as you didn’t let the charge go below about 40%.
It did catch me out a few times though and after the most recent, the battery showed 2% on restart, which was ‘normal’ but then refused to charge. It’s now discharged to 0% and so I’m absolutely reliant on AC power.

HP claims the fault requires a new motherboard to fix and has agreed to bend the rules so an engineer can do the swap/reimage on-site, otherwise I’d be without my computer for at least a fortnight, which I can’t really do.

At the moment, HP can’t get hold of the parts, so I can’t update on progress, but the current date is 25th Feb, so we’ll see if that holds.
Does this behaviour sound familiar?

Sure does. As I reported about two (?) years ago, my X2 would hang on boot and eventually required three MB replacements before the problem was remedied! However, since then my X2 has been solid as a rock. Go ahead and get your MB replaced, but make sure that HP agrees to continue working the problem until it is fixed, regardless of warranty status. They may not agree, but I think you’ve got a strong case…

Good luck…

1 Like

Thanks Steve, I told HP support about your three MBs when asking about how long they’d support me after the fix!

Weirdly, the hardware keys on the LH side of my screen don’t work any more either - just the left mind you…

Did you stick with the HP OS image after the new motherboard, or do a fresh install?
I did a fresh install when I bought mine and wonder if it was the right choice.

@incredulous : Absolutely! Because of the uncertainty of what was going wrong, having HP control BOTH the hardware and the software load was the only way to ensure they (and I) would have a full opportunity to troubleshoot the problem. Also, that ensured that all the drivers were properly installed and operating. The HP image worked fine right up to the point where I migrated to Win11 last month.

As a somewhat unrelated aside, I’ve never understood people who buy a new computer and promptly wipe the OEM image and “clean install” Windows. For one thing, wiping the OEM image prevents them for experiencing how the OEM intended the computer to work (and if they don’t like it, THEN they can wipe and clean install). For another, I think it’s asking for trouble as the result of improperly installed or missing drivers. Finally, “software bloat” may have been an issue in years past, but modern storage components make it essentially irrelevant… and software bloat itself has become less and less of a problem in modern OS images.

Not ranting at you, just expressing my personal POV…

Thanks @SteveS not taken as a rant at all, I was one of those people and I think I regret it!

Aside from the challenges it presents for repair, lifecycle extension through re-selling, or 3rd party remanufacturing, with predictable environmental consequences, early e-waste etc, I had a dim view of factory OS images because I’d had plenty of issues with bloatware in the past and good experience with scratch-built desktop PCs.
I’d also had a great outcome clean installing windows 10 to upgrade both my mum’s Surface Pro 2 and my dad’s Fujitsu Lifebook U904 from the Win 8.1 they came with. Both have been flawless ever since and still in daily use.
Sadly, only my dad was able to buy a replacement battery for his machine, so my mum is now forced to throw away a computer she loves and which works brilliantly for her needs (which includes light photoshop work as she’s an artist).
In the meantime, I’ve had two high-end convertibles, both of which have given me trouble (although the Sony was a disaster, the HP just the current issue besides some niggles).

In my defence, I discussed the prospect of doing a clean install at great length with HP tech support before buying my X2 and was assured HP hadn’t tweaked the OS and as long as I used the HP softpaq tool to keep drivers up to date, I’d be golden!

Anyhow, I’m about to find out what the X2 is like with the factory image and I’ll be sure to save a system image to my external HDD before I install anything!

Are you still on Win 11?
I like my taskbar at the top, so that alone means it doesn’t appeal (what a curmudgeon I know!)

@incredulous : Yes. Although I miss a few Win10 features, life moves on. So far, Win11 is working well in all the fundamental ways that really matter and I’m slowly getting accustomed to the differences…

I have to ask: why did you make the change to Win 11 in the first place - were you expecting any performance gains, or something else enticed you?

I read somewhere that 32bit software isn’t supported, has that been an issue?

I made the switch to Win11 on my X2 because, after test-driving it for weeks on my Surface Pro 8, I saw no reason not to. Win11 is where the currant discussions on the forum are focused, and I make it a point to be reasonably up to date with my technology because that’s the only way that one can comment knowledgably. It was really no more than that. If Win10 satisfies your needs, then stick with it (but sooner or later, Microsoft is going to force you to update)…

As for software, all of my apps are 64-bit these days, so 32-bit support is not an issue…